May 19, 2022, 09:50:02 PM

Author Topic: might have answer  (Read 6476 times)

jrwoody6861

  • Member
  • *
  • Posts: 3
might have answer
« on: September 24, 2004, 04:43:06 PM »
I have recently installed SP2 for XP and now scanning and discovery do not work as expected.  When I do a discover on a range of IP addresses, I usually see the W2K file server and nothing else.  If I try to scan a previously discovered computer from a saved file, Newt does the scan and questions as to whether the computer I am attempting to scan is off.

When I do the same operations from a computer without SP2 everything looks OK.

I really like this tool, please tell me it is something that can be fixed.

Thanks,

JRWoody

Komodo Support

  • Administrator
  • Member
  • *****
  • Posts: 2700
  • Dayton, Ohio, USA
    • Komodo Laboratories LLC
might have answer
« Reply #1 on: September 25, 2004, 02:35:10 AM »
Hello.  We apologize for the inconvenience.  There were some IP discovery issues with 1.0 that we've addressed in the latest beta of 2.0.

Unfortunately version 2 isn't out yet, but we've been offering it to our registered users since it has a lot of great new features and is nearing completion.

We will email a link to you soon on where to download the latest version.

fcleveland

  • Member
  • *
  • Posts: 5
might have answer
« Reply #2 on: September 27, 2004, 03:49:07 PM »
I am having the same issue.  I recently purchased Newt and scanned and saved the computers on my Network to a file in Newt.  Now, since upgrading to SP2, I cannot Scan or Discover new computers on the network.  

How do I download the new Beta?

Thanks,

fcleveland

Komodo Support

  • Administrator
  • Member
  • *****
  • Posts: 2700
  • Dayton, Ohio, USA
    • Komodo Laboratories LLC
might have answer
« Reply #3 on: September 27, 2004, 05:17:30 PM »
Hello, we're not sure why SP2 is giving you a problem, but 2.0 beta does not contain any kind of fix for a known issue with XP/SP2.  

We will investigate this further with you through emails, and you may have access to the beta.

mystrwizard

  • Member
  • *
  • Posts: 1
might have answer
« Reply #4 on: October 26, 2004, 03:06:41 PM »
Found this on another network inventory website about the SP2 problem blocking the discovery.  Thought this might help.

Q: Why I can't view information from a user PC with Windows XP SP2?
A: By default, the Windows Firewall blocks all incoming RPC traffic.
How will i fix it?
Windows Firewall includes a Remote Administration option that alters its configuration to allow Remote Procedure Call (RPC) and Distributed Component Object Model (DCOM) communication. Enabling Remote Administration option statically opens TCP 135 and TCP 445 to unsolicited incoming traffic. Additionally, communication over named pipes is permitted, and ports will be dynamically opened as needed by Windows services using RPC
To enable Remote Administration by default in the Domain Profile, add the following entry to the ICF.AddReg.DomainProfile section of the Windows Firewall INF file:
HKLM,"SYSTEM\\CurrentControlSet\\Services\\SharedAccess\\Parameters \\FirewallPolicy\\DomainProfile \\RemoteAdminSettings", "Enabled", 0x00010001,1
Script for enabling the remote administration
Set objFirewall = CreateObject("HNetCfg.FwMgr")
Set objPolicy = objFirewall.LocalPolicy.CurrentProfile
Set objAdminSettings = objPolicy.RemoteAdminSettings
objAdminSettings.Enabled = TRUE

fcleveland

  • Member
  • *
  • Posts: 5
might have answer
« Reply #5 on: October 26, 2004, 03:43:36 PM »
On the computer you are trying to read, under Control Panel, Windows Firewall, Advanced tab, make sure File and Print Sharing is selected.

I was having the same issue and this resolved it.

FC

Komodo Support

  • Administrator
  • Member
  • *****
  • Posts: 2700
  • Dayton, Ohio, USA
    • Komodo Laboratories LLC
might have answer
« Reply #6 on: October 26, 2004, 04:33:14 PM »
Ah yes, the dreaded SP2 firewall.

Those are two ways to fix it.  One is to leave the firewall on, but enable certain things as mystrwizard has shown.  Thanks for the info!  And the other is just to disable it completely just as it was before you installed SP2.  Before SP2, Windows XP came with a firewall, it just wasn't enabled by default.  Microsoft decided to protect all of us by changing a few settings when installing SP2.  This creates a big headache for IT people in general who already have an even better hardware firewall between the network and the Internet.

If push-installing SP2 across your network, there *should* be a command line option to tell SP2 *not* to enable that pesky firewall during the actual install.  This will save you a great deal of time if you have many machines.