October 03, 2022, 01:20:16 PM

Author Topic: WMI: The RPC server is unavailable.  (Read 8523 times)

richard

  • Member
  • *
  • Posts: 3
WMI: The RPC server is unavailable.
« on: April 08, 2005, 11:09:57 AM »
I am using the 10 machine licence of Newt Pro v2.0 Build 2261.
The HP Servers & PCs are in a Windows domain and I am running Newt using the domain administrator account. Some the of fields do not produce any data:

Motherboard Manufacturer - WMI:access is denied
System Model - WMI:For loop not initialized
Serial Number - WMI:access is denied
Drivers-Logical Tab is empty
RAM slots Tab is empty
Services Tab is empty
System Slots Tab is empty

Anything I can do to populate these fields?

thanks

richard

Komodo Support

  • Administrator
  • Member
  • *****
  • Posts: 2701
  • Dayton, Ohio, USA
    • Komodo Laboratories LLC
WMI: The RPC server is unavailable.
« Reply #1 on: April 08, 2005, 10:19:36 PM »
Hi Richard.  Could there be a software firewall may be turned on for these machines?

If this is the case, please try running this file locally on one of them to open up WMI for the firewall:
http://www.komodolabs.com/OpenFireWallForWMI.zip

Please let us know if this works for you.  If not, we can explore other avenues.

richard

  • Member
  • *
  • Posts: 3
WMI: The RPC server is unavailable.
« Reply #2 on: April 09, 2005, 09:29:37 AM »
Both machines are servers running W2K with no firewall software on my PC or the  servers. Also there is no hardware firewall between my PC and the servers.

Komodo Support

  • Administrator
  • Member
  • *****
  • Posts: 2701
  • Dayton, Ohio, USA
    • Komodo Laboratories LLC
WMI: The RPC server is unavailable.
« Reply #3 on: April 11, 2005, 08:12:04 PM »
Hello again.  We apologize for the late reply.

Are you able to get most other data including Software?

richard

  • Member
  • *
  • Posts: 3
WMI: The RPC server is unavailable.
« Reply #4 on: April 12, 2005, 11:19:59 AM »
I think the problem was DCOM related. My PC (W2K SP4) did not have DCOM enabled.  Enabling it, using DCOMCNFG, seems to have fixed the problem.

Is DCOM disabled by default on W2k?

Komodo Support

  • Administrator
  • Member
  • *****
  • Posts: 2701
  • Dayton, Ohio, USA
    • Komodo Laboratories LLC
WMI: The RPC server is unavailable.
« Reply #5 on: April 13, 2005, 10:33:10 AM »
Hi.  DCOM should actually be enabled by default in W2K.  It could be that a program or another user disabled it.

Thanks for letting us know.  If other users report a similar issue we\'ll be able to help them better.

Francine

  • Member
  • *
  • Posts: 2
WMI: The RPC server is unavailable.
« Reply #6 on: June 29, 2005, 11:05:40 AM »
I keep getting this on some of my machines.  I am running a 500 user license and for all that I have checked the configurations of services and firewall are the same between a machine that scans ok with the ones getting the error.

Also getting network path not found on other machines, which are also configured the same, turned on and functioning on the network.

Being a new user, I suspect I am missing something.  All help appreciated.

Francine

  • Member
  • *
  • Posts: 2
WMI: The RPC server is unavailable.
« Reply #7 on: June 29, 2005, 11:06:37 AM »
Also, all machines are XP, SP2 or Server 2003.

Komodo Support

  • Administrator
  • Member
  • *****
  • Posts: 2701
  • Dayton, Ohio, USA
    • Komodo Laboratories LLC
WMI: The RPC server is unavailable.
« Reply #8 on: June 29, 2005, 11:22:25 AM »
Hello Francine.  There can be many reasons why you\'re getting these errors, most related to Windows or Windows security.  We are working on a self-help system, but we\'re trying to help users on an individual basis until then.

We will contact you by email to get more information from you.